خوش آمديد!
14:45 چهارشنبه 2 اسفند ماه ، 1396
سايت مهندس لاچيني | پروژه ها و آموزش الكترونيك و تابلوروان: تالار گفتمان

HLachini.elewiz.com :: نمايش موضوعات - مشکل کامپایل در بسکام

مشکل کامپایل در بسکام

 

ارسال موضوع جديد  پاسخ به اين موضوع   ارسال تشکر 

   HLachini.elewiz.com صفحه اول انجمن -> AVR

نمايش موضوع قبلي :: نمايش موضوع بعدي  
نويسنده پيغام

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: سه شنبه، 7 تير ماه ، 1390 08:05:41    موضوع مطلب: مشکل کامپایل در بسکام پاسخ همراه با اعلان

سلام
خسته نباشید

چند روزی هست هر برنامه ای با بسکام می نویسم روی آی سی کار نمی کنه

مثل همیشه برنامه را کامپایل می کنم سپس send to chip می کنم

اما آی سی کار نمی کنه.
(پروگرام می شه چون write و verify صورت میگیره و خطا نمیگیره تغدیه مدار هم درسته با یه ای سی که قبلا پروگرام کردم هم کار می کنه اما حالا روی هر آی سی که اطلاعات می ریزم کار نمی کنه ) مشکل از کد هم نیست چون همین کد قبلا کار میکرد و در ضمن روی اون آی سی که قبلا پروگرام کرده بودم همین کد را ریخته بودم اما حالا همین کد روی یه آی سی دیگه می خوام بریزم جواب نمیده حسابی گیج شدم . شرایط کاملا یکسان .

آدرس پورت موازی را هم چک کردم درست بود.


از دو پروگرامر مجزا هم استفاده کردم فایده نداشت یکی stk200 ساخت خودم و دیگری stk500 ساخت شرکت نوآوران الکترونیک با کد nus112

باز هم عمل نکرد

از ورژن های مختلف بسکام استفاده کردم بازهم فایده نداشت

ویندوز را عوض کردم یکی دو بار کار کرد اما بعد از اینکه در option بسکام تیک optimize code را گذاشتم تا برنامه ای که 113 درصد فضا از mega8 من بگیره به 93 درصد برسه یک بار کار کرد و دوبار خراب شد حالا گیر افتادم یک هفته هست لنگ موندم


احتمالا فایل هگزی که می سازه به درد نمی خوره

اگه میشه کمکم کنید
مرسی

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي
تشکرهاي ثبت شده از ايجاد کننده تاپيک :
aliroosta(چهارشنبه، 8 تير ماه ، 1390 07:00:47), 5696(يكشنبه، 4 مرداد ماه ، 1394 23:03:25),  

adelavr
کاربر فعال
کاربر فعال

وضعيت: آفلاين
2 شهريور ماه ، 1388
تعداد ارسالها: 305
امتياز: 603
تشکر کرده: 4
تشکر شده 45 بار در 12 پست

محل سكونت: تبریز

ارسالارسال شده در: سه شنبه، 7 تير ماه ، 1390 23:42:07    موضوع مطلب: پاسخ همراه با اعلان

بعد از اینکه verify میشه پیغام verify ok می آد یا نه؟
میکرو رو هم عوض کن و با یه میکرو نو امتحان کن
اگه همه اینکارا نشد با یه نرم افزار دیگه پروگرم کن

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي ارسال ايميل بازديد از سايت ارسال كننده مطلب
کاربرانی که برای این ارسال از adelavr تشکر کرده اند aliroosta

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: چهارشنبه، 8 تير ماه ، 1390 07:14:27    موضوع مطلب: پاسخ همراه با اعلان

سلام دوست عزیز

مرسی از اینکه جوابم دادید


از چند آی سی جدید هم استفاده کردم فایده نداشت البته یک آی سی که با همین سورس کد کار می کنه را که قبلا پروگرام کرده بودم داشتم و دیدم مدار هم سالمه

اما چون می خوام این سورسو کامل کنم باید بتونم دوباره پروگرام کنم که مقدور نیست

در ضمن بد از وریفای اوکی می داد


از ورژن های مختلف بسکام هم استفاده کردم فایده نداشت

بعد از اینکه ویندوز را عوض کردم یکی دوبار درست عمل کرد اما باز خراب شد بعد از تغییر تیکهای option بسکام

و البته نمی تونم بعد از هر تغییر کوچیک در برنامه ویندوز را عوض کنم

متشکرم از توجهتون

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

adelavr
کاربر فعال
کاربر فعال

وضعيت: آفلاين
2 شهريور ماه ، 1388
تعداد ارسالها: 305
امتياز: 603
تشکر کرده: 4
تشکر شده 45 بار در 12 پست

محل سكونت: تبریز

ارسالارسال شده در: چهارشنبه، 8 تير ماه ، 1390 17:49:22    موضوع مطلب: پاسخ همراه با اعلان

اگه وریفای اوکی رو میده باید برنامه درست ریخته شده باشه
فکر کنم تغذیه میکرو یه کم مشکل داره

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي ارسال ايميل بازديد از سايت ارسال كننده مطلب
کاربرانی که برای این ارسال از adelavr تشکر کرده اند aliroosta

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: شنبه، 11 تير ماه ، 1390 09:39:36    موضوع مطلب: پاسخ همراه با اعلان

متشکرم دوست عزیز

اما متاسفانه مشکل از تغذیه نیز نیست چون یه آی سی دیگه که قبلا همین کد را با همین فیوز بیت هاست پروگرم کرده بودم الان وقتی میزارم کار میکنه اما همین سورس را وقتی روی یه آی سی دیگ می ریزم کار نمی کنه

این مشکل 1 هفته هست که پیش اومده و من روی این پروژه بیش از 1 ماه هست که دارم کار می کنم اما جدیدا این مشکل پیش اومده

مطمعنم مشکل از مدار - سورس کد - پروگرمر نیست ادرس LPT - نوع پروگرمر نیست

لطفا به مسائل خارج از PC نپردازید چون مطمئن هستم همشو کنترل کردم

اگه کسی فکر می کند و یندوز می تونه یه همچین مشکلی را پیش بیاره لطف کنه راهنمایی کنه

چون 8 ساله دارم با بسکام کار می کنم و این اولین دفعه هست به یه همچین مشکلی می خورم

در ضمن حالا هر نو میکرویی و هر نوع آی سی با هر کدی که بگید تست کردم کار نمیکنه اما پروگرم می شه


حتی خاموش روشن شدن یه ال ای دی ساده


Question

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: شنبه، 11 تير ماه ، 1390 09:44:01    موضوع مطلب: پاسخ همراه با اعلان

ویندوزم هم همون ویندوز XP SP3 هست که مدتها دارم با اون کار می کنم فایر والم را هم از کار انداختم
هیچوقت ویندوزم را هم آپ دیت نمی کنم از ترس یه همچین مشکلاتی


ما هم باید بریم بمیریم چون همه نرم افزارامون دزدی هست از ویندوز گرفته تا بسکام

اه اه اه Shocked

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

adelavr
کاربر فعال
کاربر فعال

وضعيت: آفلاين
2 شهريور ماه ، 1388
تعداد ارسالها: 305
امتياز: 603
تشکر کرده: 4
تشکر شده 45 بار در 12 پست

محل سكونت: تبریز

ارسالارسال شده در: شنبه، 11 تير ماه ، 1390 23:51:21    موضوع مطلب: پاسخ همراه با اعلان

شما گفتید با تغییر دادن چند گزینه در بسکام این مشکل به وجود اومد
خب یه فایل هگز که یه برنامه ساده توش هست (که توسط بسکام کامپایل نشده) رو با یه نرم افزار دیگه مثل Khazama AVR Programer (البته باید با اون نرم افزار از پروگرمر USBASP استفاده کنی) بریز تو میکرو و روی یه برد بورد تازه و سالم امتحانش کن اینطوری مشکلتو پیدا میکنی موفق باشی

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي ارسال ايميل بازديد از سايت ارسال كننده مطلب
کاربرانی که برای این ارسال از adelavr تشکر کرده اند aliroosta

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: يكشنبه، 12 تير ماه ، 1390 09:50:37    موضوع مطلب: پاسخ همراه با اعلان

متشکرم

اما دوست خوب و عزیزم
همین فایل هگز را توسط دو تا پروگرمر مجزا stk200 , stk500 هر بار با دو نرم افزار مجزای بسکام و avrstudio روی آی سی ریختم اما کار نکرد

دقیقا به همین علت بود که گفتم فایل هگز خوب ساخته نمی شه

و مشکل از کامپایل شدن هست

بدبختانه 1 را دیگه بیشتر نمونده اونم اینکه با کدویژن یا winavr یه فایل هگز بسازم

اون هم به علت اینکه این پروژه خیلی جلو رفته مقدور نیست و تسلط من روی بسکام می باشد

با اینکه از بسکام خیلی خوشم می یاد( چون توابع خیلی توپی داره) فکر کنم باید برم سراغ کدویژن

Shocked

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

adelavr
کاربر فعال
کاربر فعال

وضعيت: آفلاين
2 شهريور ماه ، 1388
تعداد ارسالها: 305
امتياز: 603
تشکر کرده: 4
تشکر شده 45 بار در 12 پست

محل سكونت: تبریز

ارسالارسال شده در: دوشنبه، 13 تير ماه ، 1390 12:31:46    موضوع مطلب: پاسخ همراه با اعلان

تو یه سیستم دیگه یه برنامه خیلی ساده بنویس و با بسکام کامپایل کن و بعد پروگرم کن و امتحانش کن
من هم نگفتم که بسکام رو بی خیال شو اینکار برای من هم محاله خواستم فقط بدونی مشکلت واقعا از بسکام هست یا نه؟

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي ارسال ايميل بازديد از سايت ارسال كننده مطلب
کاربرانی که برای این ارسال از adelavr تشکر کرده اند aliroosta

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: دوشنبه، 13 تير ماه ، 1390 16:49:13    موضوع مطلب: پاسخ همراه با اعلان

سلام

خیلی متشکر از پیگیری مشکل من

همین کار ها را روی چندتا سیستم دیگه انجام دادم اما به یه همچین مشکلی بر نخوردم

به نظر می رسه بسکام با سیستم من درگیری داره

قبلا اینجوری نبودا اما مثل اینکه سیستم من حالش تب داره Laughing

فکر نمی کنم سخت افزاری هم باشه چون بعد از نصب ویندوز کی دو بار کر می کنه

با نوع ویندوز هم مشکل نداره چون از روی دوتا سی دی مختلف از ویندوز اکس پی کار کردم

گیج شدم این قضیه شده مثل خربزه و عسل

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: يكشنبه، 19 تير ماه ، 1390 15:56:37    موضوع مطلب: پاسخ همراه با اعلان

سلام
بالاخره مشکمو دقیقا فهمیدم از کجاست اما نمی تونم برطرفش کنم. Laughing

بسکام فایل هگز جدید نمی سازه
یعنی همون فایل هگز خرابی که کار نمی کنه را روی آی سی می ریزه

حتی تمام فایل های hex-bin,... را پاک کردم و فقط فایل bas را باقی گذاشتم اما بازم معلوم نیست این فایل هگز خراب را از کجا بر می داره میاره Shocked

کپی کردم جای دیگه

application data را پاک کردم

کد خالی ریختم

کد روشن خاموش کردن یک پایه را ریختم

هیچکدوم فایده نداشت Cool

لطفا کمک کنید

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

adelavr
کاربر فعال
کاربر فعال

وضعيت: آفلاين
2 شهريور ماه ، 1388
تعداد ارسالها: 305
امتياز: 603
تشکر کرده: 4
تشکر شده 45 بار در 12 پست

محل سكونت: تبریز

ارسالارسال شده در: چهارشنبه، 22 تير ماه ، 1390 23:36:17    موضوع مطلب: پاسخ همراه با اعلان

فکر کنم یه بار کلا بسکام رو از بیخ پاک کنی و دوباره نصب کنی مشکل حل بشه

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي ارسال ايميل بازديد از سايت ارسال كننده مطلب

aliroosta
کاربر فعال
کاربر فعال

وضعيت: آفلاين
7 مرداد ماه ، 1389
تعداد ارسالها: 9
امتياز: 17
تشکر کرده: 4
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: دوشنبه، 3 مرداد ماه ، 1390 08:00:01    موضوع مطلب: پاسخ همراه با اعلان

سلام

متشکرم از پیگیری مشکل من ، اما Uninstal و نصب مجدد که بماند ، از ورژن های مختلف بسکام هم استفاده کردم اما فایده نداشت

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي

5696
کاربر جدید
کاربر جدید

وضعيت: آفلاين
5 مرداد ماه ، 1394
تعداد ارسالها: 1
امتياز: 6
تشکر کرده: 0
تشکر شده 0 بار در 0 پست


ارسالارسال شده در: يكشنبه، 4 مرداد ماه ، 1394 23:21:49    موضوع مطلب: پاسخ همراه با اعلان

با سلام , من هم این مشکل برام پیش اومد اما تونستم مشکل رو به امید خدا حل کنم. میدونم این پست قدیمیه ولی این رو می نویسم تا اگه کسی به این مشکل برخورد بتونه اونو حل کنه. بعد از پروگرم کردن میکرو , اونو روی برد سوار کنید و با یک مقاوت 2.2k پایه xtal1 را به منفی و یک مقاوت 2.2k دیگر پایه xtal2 را به پایه منفی تغذیه وصل کنید. این کار سبب میشه تا نویز روی این دوتا پایه از بین بره. به همین راحتی. امید وارم جواب بگیرید .یا علی.

بازگشت به بالا

رويت مشخصات كاربر ارسال پيغام شخصي
تمامي مطالب ارسال شده:   
ارسال موضوع جديد   پاسخ به اين موضوع   ارسال تشکر

   HLachini.elewiz.com صفحه اول انجمن -> AVR

زمان پيشفرض سايت: ساعت گرينويچ + 3.5 ساعت
صفحه 1 از 1
  
نام کاربري:      کلمه عبور:     

~ يا ~
عضويت در سايت

  


 


Powered by phpBB © 2001, 2008 phpBB Group
پروگرامر و تستر آِی سی سانا با قابلیت تشخیص اتوماتیک قطعه و درج تمامی قطعات از پین یک زیف و تامین کلاک قابل استفاده در بسکام و کدویژن